Oculus Go开发移植必知 支持Gear VR应用 不支持谷歌Play

日期:2018-05-15编辑作者:菲律宾sunbet官网

  2018年04月21日,随着Oculus的首款VR一体机Oculus Go即将登陆市场,这家公司日前向开发者分享了如何将Gear VR应用带到Oculus Go的便捷指南。

  Oculus在官方博文中写道,Oculus Go提供对Gear VR的二进制兼容支持,而大部分支持Gear VR的应用无需进行任何更改即可在Oculus Go上启动。但Oculus指出了两款移动VR头显之间的关键不同,而开发者需要对此进行考量:

  Google Play Services:与运行Gear VR的三星Galaxy设备不同,Oculus Go未安装Google Play Services。在Oculus Go上运行应用时,你不能依赖于Google Play Services,如Google Firebase,Google Cloud Messaging等等;或者依赖于Google Play Services的第三方库,如OneSignal。

  2D表面:Oculus Go没有2D手机显示器,因此一些应用行为在Oculus Go上没有任何意义,如推送通知或通过单独的安卓应用程序进行验证。

  摄像头:Oculus Gom没有摄像头,无法运行需要访问摄像头的应用。

  头显触控板:Oculus Go没有头显触控板。当在Oculus Go运行时,你的应用不应该使用头显触控板。

  不同的控制器:Oculus Go控制器和Gear VR控制器共享相同的输入:都是支持可点击触控板和食指扳机器的3自由度控制器。虽然这两款设备提供了相同的输入,但每个设备的物理设计都有所不同。如果你的应用程序显示可见控制器,则应根据你是在Gear VR还是Oculus Go上运行来更改显示的模型。或者,你可以选择不同于Oculus Go控制器和Gear VR控制器的程式化控制器模型。

  需要最新的SDK:部分老Gear VR应用仍然是允许Mobile SDK的1.0预发行版本,而Oculus Go并不支持这种应用程序。

  另外,Oculus在博文中简单阐述了如何开发者可以考虑的一些新功能,如固定注视点渲染,动态节流和可选的72Hz模式。Oculus同时建议开发者使用特定版本的开发工具来访问这些功能:

  我们推荐使用以下工具为Oculus Go和Gear VR开发内容:

  使用Oculus Utils 1.24.1或更高版本的Unity 5.6.5p2或2017.4.2(这里描述的很多新功能都需要用到)。

  从Oculus的GitHub镜像中提取的Unreal4.18。

  对于原生代码应用,建议采用Mobile SDK 1.21或更高版本。

  Oculus最初在2017年发布,而现在许多开发者都已经拿到了设备。预计产品将很快登陆市场,最早有可能是下个月初举行的Facebook F8大会。

上一篇:Android系统或没法用了 中兴与谷歌磋商寻找解决方案
下一篇:最后一页

相关文章

Facebook、Uber、雅虎等互联网巨头数据泄露事件频频发生

  Facebook数据泄密事件在过去半个月来持续发酵,如果说账面上近千亿市值的损失还可估量,那么人心的向背则是一向爱惜羽毛的扎克伯格所不 ...

发布日期:(2018-05-15) 详细>>

Facebook成众矢之的 其实谷歌隐私问题更严重

  凤凰网科技讯 据彭博社北京时间4月16日报道,没有一名谷歌高管羡慕上周的马克·扎克伯格(Mark Zuckerberg),但多年来,他们对使Faceb ...

发布日期:(2018-05-15) 详细>>

Facebook数据泄露丑闻发酵:谷歌隐私策略遭指责

    新浪科技讯 北京时间4月17日早间消息,Facebook近期遭遇的数据泄露丑闻也在对谷歌造成影响。美国国会议员正呼吁更广泛的隐私监管 ...

发布日期:(2018-05-15) 详细>>

Facebook也要自己造芯片了:还有苹果、谷歌和亚马逊

  据Bloomberg报道,Facebook目前正在招募一个半导体专业研发团队,以打造属于自己的芯片,未来或应用到Facebook发布的硬件产品、数据中 ...

发布日期:(2018-05-15) 详细>>

Facebook之后 下一个经受拷问的会是谷歌吗?

  前不久 Facebook因剑桥分析(Cambidge Analytica)事件卷入了泄露用户信息的风波,马克·扎克伯格近日在美国国会参加了听证会。Faceb ...

发布日期:(2018-05-15) 详细>>